Stupidly long class name or a geeky poem?

In the JRE is a stupidly long class name, only a code generator could produce such a long name. (Which the developer of the code generator never checked I assume) InternalFrameInternalFrameTitlePaneInternalFrameTitlePaneMaximizeButtonWindowNotFocusedState

Or is it a geeky poem burried in the code?

InternalFrame InternalFrame 
Title Pane,
Internal Frame
Title Pane.

Maximize Button Window,
Not Focused State.

The moral of the story, always check the readability/sanity of generated code.


Popular posts from this blog

Java is Very Fast, If You Don’t Create Many Objects

System wide unique nanosecond timestamps

Comparing Approaches to Durability in Low Latency Messaging Queues